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The company
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• Intecs - Italian company with activities in:
• Defense
• Railway
• Aerospace
• Traffic Control & Surveillance
• Automotive
• Telecom

• Approx. 500 employees over 6 cities in Italy (not only)

• Purpose of these classes: getting familiar with the 
world of embedded systems and microcontrollers.
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Introducing myself
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• PhD in computer engineering @diag

• Focus on wireless sensor networks and low power 
devices.

• Since 2012 partner of Wsense (university spin-off): hw 
+ microcontroller software development.

• In Intecs since October 2016: head of HW Lab in 
Rome, embedded sw developer/hw designer.
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Tools used in this class (1/4)
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The development board:
St-link debugger

STM32F401RE MCU

User Led

User Button

32 Khz Crystal

USB connector

Expansion Pins

Arduino – compatible
pins

Debugger

MCU
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Nucleo-F401RE
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Tools used in this class (2/4)

Sensor expansion board:

X-Nucleo-IKS01A2

Temp./Hum. Sensor
(HTS221)

Temp./Pressure Sensor
(LPS22HB)

Accel./Gyro. Sensor
(LSM6DSL)

Accel./Compass Sensor
(LSM303AGR)

Level Shifters

DIL24 socket
(expansion conn.)
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Tools used in this class (3/4)

Bluetooth expansion board:

X-Nucleo-IDB05A1

Bluetooth module
(SPBTLE-RF)
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Framework, IDE & tools

System Workbench 4

STM CubeMX

Stm32CubeF4
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Tools used in this class (4/4)



The Microcontroller
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Stm32F401 Microcontroller:
•Based on Cortex M4 processor
•512KB ROM Flash memory
•96KB SRAM data memory
•Up to 84Mhz operating frequency
•42uA in sleep (stop mode) w/RTC

Available packages
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Architecture
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Architecture
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Architecture
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Architecture
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Architecture
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Architecture
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Architecture
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Architecture
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Architecture
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Architecture
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Cortex M-4
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• Cortex M-4
• Armv7-m architecture: Harvard architecture, 32-bit architecture 

(internal registers, data path, bus interface)

• Thumb-2 instruction set (16/32 instructions)

• Unified memory space 4GB

• On-chip bus interfaces based on ARM AMBA

• NVIC controller with priority levels (12 clock cycles)

• Systick timer

• Optimized for power consumption (alternatives: Cortex R or 
Cortex A)

• Optional advanced debug features and MPU
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Cortex M-4
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Address space: 4GB, little/big endian
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Cortex M-4
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• Systick Timer
• Part of the NVIC, 24-bit decrement timer

• Sourced from a reference clock source (typ. on-chip)

• Has its own exception hanlder

• Can be used as system clock for an OS (task management, 
context switch)

• Used for portability
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Cortex M-4
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• Power consumption:
• Various sleep modes available

• Commands: Wait For Event (WFE) / Wait For Interrupt (WFI)

• Code stops running

• Based on the sleep mode, clock signals can selectively be turned 
off:
• Deeper sleep mode -> less peripherals running

• Deeper sleep mode -> higher wakeup time

• Deeper sleep mode -> less wake-up sources 
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Stm32L476 Lookup
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• Clock Sources:
• External 4-26 Mhz crystal osc. (HSE)

• Internal 16Mhz factory-trimmed RC (HSI16)

• Internal 32 Khz low power RC (LSI)

• External 32 Khz crystal for RTC (LSE)

• System PLL (uses HSE,HSI16) up to 84Mhz

• At startup, the MCU uses HSI at 16Mhz

• Clock sources managed by Reset and Clock Control 
(RCC) module
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Stm32L476 Lookup
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• Peripherals:
• 11 x Timers

• 6 x 16bit low power
• 2 x 32bit
• 2 x Watchdogs
• 1 x Systick timer

• 1 x RTC
• 1 x ADC 12 bit

•2 x SAI Interfaces
•3 x I2C
•3 x USART 
•4 x SPI (+ I2S)
•1 x DMA 16 ch.
•1 x SDIO
•1 x USB OTG FS
•81 x GPIO
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Getting Started with CubeMX
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STM CubeMX
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• Configuration tool:
• Clock sources
• Peripherals
• Pinout
• Middlewares

• Code generation:
• IDE support
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STM CubeMX
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• Step 1:
• Launch CubeMX
• Select “New Project”
• Choose “Board Selector”
• Vendor “ST 

Microelectronics”
• Type of Board “Nucleo 64”
• MCU Series “Stm32F4”
• Select “Nucleo-F401RE”
• Double click on it

Usage Example: Clock and Timer 1 configuration
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STM CubeMX
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• Step 2:
• From “Pinout” tab
• Expand “RCC”
• Select “Crystal/Ceramic 

resonator” in Low Speed 
Clock (LSE) 

• This will enable external 
32Khz crystal of the 
Nucleo Board

Usage Example: Clock and LPTimer 1 configuration
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STM CubeMX
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• Step 3:
• From “Pinout” tab
• Expand “TIM1”
• Select “Internal Clock” 

as clock source

Usage Example: Clock and Timer 1 configuration
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STM CubeMX
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• Step 4:
• From “Clock Configuration” tab
• Leave HSI@84Mhz in System Clock Mux

Usage Example: Clock and Timer 1 configuration
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STM CubeMX
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• Step 5:
• Q: Which bus is connected to TIM1?
• Annotate its frequency

Usage Example: Clock and Timer 1 configuration
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STM CubeMX
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Step 7:
•From “Configuration” tab
•Check that peripherals and clocks are set correctly
•Double click on TIM1, select counter period to be 65535
•Q: What prescaler and division should we set for 1ms tick timer?
•NVIC settings enable TIM1 update interrupt

Usage Example: Clock and Timer 1 configuration
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STM CubeMX
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• Step 1:
• Click on “Project” -> “Settings”
• In “Project” tab
• Set a project name
• Select SW4STM32 IDE
• Check that MCU and 

Firmware package are correct

Usage Example: Code Generation
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STM CubeMX
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• Step 2:
• In “Code Generator” tab
• Select “Generate peripheral 

initialization…”
• Keep other options unchanged
• Click on “OK”

Usage Example: Code Generation
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STM CubeMX
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• Step 3:
• Click on “Project” -> “Generate 

Code”
• Wait the end of the execution
• You can now import the 

project on System Workbench 
4

Usage Example: Code Generation

Intecs Solutions 2018 Roma-Genova-Milano-Napoli-Pisa-Torino



System Workbench 4

Importing project and debugging

36Intecs Solutions 2018 – Roma-Genova-Milano-Napoli-Pisa-Torino



System Workbench 4

37

• Step 1:
• Launch SW4STM32
• In “File” menu click on “import…”
• In “General”, select “Existing 

Project into Workspace”
• Select the root folder generated 

with CubeMx
• Keep default options and click 

finish

Importing project generated with CubeMX
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System Workbench 4
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• Step 2:
• Right click on the project and select “Build Project”
• Wait for compilation to finish and check that no 

errors were generated

Importing project generated with CubeMX
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System Workbench 4
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• Step 3:
• Plug the nucleo
• Right click on the project and select “Debug as”
• When prompted to switch in debug view click yes (check the “keep 

option”  if you don’t want to repeat this step each time)
• The code will halt on HAL_Init()
• Click on “step over” or “step into” to get familiar with the IDE in 

debugging mode
• You can click on “Resume” if you want your code to freely run (but it 

won’t do anything since it’s empty  )

Importing project generated with CubeMX
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System Workbench 4
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• In project explorer: STM32F401RETx_FLASH.ld
• Where to find program and data memory (RAM,FLASH) w.r.t. the linear memory 

map of the MCU
• What to put inside each area (e.g., .isr_vector, .text and constant data in flash, 

.data and .bss in ram etc…)

Important files: the linker script
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System Workbench 4
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• Quick recall on memory segments:

Important files: the linker script

Dynamic memory allocation (e.g., malloc,…)

Automatic variables,
returned address …

Global or static variables initialized to 0 or not explicitly initialized

Global or static variable with pre-defined value and that can be modified

Read only data (e.g., code)
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System Workbench 4
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• Quick recall on memory segments:

Important files: the linker script
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System Workbench 4
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• Quick recall on memory segments:

Important files: the linker script
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System Workbench 4
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• Quick recall on memory segments:

Important files: the linker script
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System Workbench 4

45

• Quick recall on memory segments:

Important files: the linker script
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System Workbench 4

46

• startup/startup_stm32f401xe.s
• Written in assembly, it holds the reset handler (first code to be executed) and the 

vector table

Important files: the startup file
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System Workbench 4
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• Src/system_stm32f4xx.c
• SystemInit function for clock and vector table initialization
• Other clock utilities…

Important files: the system file
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System Workbench 4
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• Drivers/STM32L4xx_HAL_Driver/stm32l4xx_hal_[peripheral].c

Important files: peripherals initialization

Important files: Hardware Abstraction Layer drivers

• Src/tim.c
• Src/gpio.c

• MX_[peripheral]_init: high-level init

• HAL_[peripheral]_init: low-level init
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System Workbench 4
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• Src/stm32f4xx_it.c
• Glue code between HAL peripheral and your code: 

• Interrupt handlers in the vector table are not directly defined in the HAL 
layer.

• User can define them in the stm32f4xx_it.c file and call the HAL_Handler in 
it.

Important files: interrupt management

stm32f4xx_it.c

stm32f4xx_hal_tim.c

Intecs Solutions 2018– Roma-Genova-Milano-Napoli-Pisa-Torino

TIM1

MCU interrupt
TIM1_UP_TIM10IRQHandler

startup_stm32f401xe.s
Void 

TIM1_UP_TIM10_IRQHandler()
{….}

Void HAL_TIM_IRQHandler() 
{….}

HAL_TIM_IC_CaptureCallback(…)

HAL_TIM_PeriodElapsedCallback(…)

etc…(…)

main.c



System Workbench 4
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• Plug the Stm32F401 board
• Right click on the project and select “Debug as…” and select “Ac6 Stm32 C/C++ 

Application”
• This will trigger a recompilation (but it’s already done)
• Then the board will be programmed and the mcu reset
• The program will halt by default at the beginning of the main function

Launching and debugging
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System Workbench 4
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Useful views during a breakpoint
•Variables: shows (some?) global and automatic variables with their values
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System Workbench 4
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Useful views during a breakpoint
•Registers: shows the values of all the MCU registers
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System Workbench 4
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Useful views during a breakpoint
•I/O Registers: detailed view of all peripheral registers with their offsets and values
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System Workbench 4
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Useful views during a breakpoint
•Disassembly: disassembled code on the go (not always reliable)
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System Workbench 4
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Useful views during a breakpoint
•Memory Browser: allows to browse over the entire linear memory of the MCU
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System Workbench 4
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Hands-on: Le’ts put a breakpoint on the Reset Handler…

•The first steps of the cortex-m during power on are:
• Load address 0x0 (address of the stack pointer) in the stack 

pointer register (MSP)
• Load address 0x4 (address of the reset handler) in the program 

counter (PC)

•After re-running “debug as”:
• Follow the boot sequence up to the main
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System Workbench 4
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Hands on: let’s switch on the led (LD2)
•Just one line of code in the main.c…
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System Workbench 4
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Hands on: let’s switch on the led (LD2)

•Let’s have a closer look to what it is happening through the debugger…
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System Workbench 4
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Hands on: let’s toggle the led (LD2) each 500ms

•Using the HAL library and systick timer:

main.c

stm32l4xx_it.c

Intecs Solutions 2018– Roma-Genova-Milano-Napoli-Pisa-Torino

Polls uwTick which increases by one at each 
systick interrupt (check with the debugger)



System Workbench 4

SW4 – CubeMX integration
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SW4 – CubeMX Integration
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• Step 1:
• Launch SW4STM32
• In “File” menu click on “new”
• Select “C project”
• Enter the project name
• Make sure you select “Empty 

Project” with “AC6” toolchain
• Click on “Next”

Create a plain project
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• Step 2:
• Select “Debug” and “Release”
• Click on “Next”
• Select STM32F4 as “Series”
• Select Nucleo-F401RE as 

“Board”
• Click on “Next”

Create a plain project

SW4 – CubeMX Integration
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• Step 3:
• Select “Hardware Abstraction 

Layer” and keep the rest 
unchanged

• Download the framework if you do 
not have it

• Click on “Finish”

Create a plain project

SW4 – CubeMX Integration
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• Pros:
• All HAL drivers available
• Board Support Packages (BSP) 

drivers for external peripherals 
(button,led on nucleo-64)

• Cons:
• Missing peripheral and HAL setup
• Compiles all the files (even HAL 

drivers that are not used)

Create a plain project

SW4 – CubeMX Integration
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Merging with CubeMX

• Step 1:
• Create a plain project in SW4
• Create a project in CubeMX with 

Clock and peripheral initialized
• Copy the peripheral configuration 

files (e.g. gpio.c) from src in 
CubeMX to src in SW4

• Do the same with header files 
(e.g. gpio.h) in the inc folder

SW4 – CubeMX Integration
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Merging with CubeMX

• Step 2:
• Copy the main.h header file from 

inc folder of CubeMX to inc folder 
of SW4

• Replace the stm32f4xx_it.c 
(and .h) file in SW4 with the one in 
CubeMX

• Copy the stm32f4xx_hal_msp.c 
file from CubeMX to SW4

• Remove the 
stm32f4xx_hal_msp_template.c 
file from HAL_Driver/Src (or right-
click on it and select Resoure 
Configurations->exclude from 
build and select Debug and 
Release)

SW4 – CubeMX Integration
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Merging with CubeMX

• Step 3:
• Edit main.c of SW4 by including 

the imported header files (main.h, 
gpio.h etc…)

• If a peripheral configuration file 
has a handle variable (e.g. 
TIM1_HandleTypeDef), declare it 
as extern in the main file

SW4 – CubeMX Integration
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Merging with CubeMX

• Step 4:
• Copy the SystemClock_Config 

and the ErrorHandler functions 
from the main.c of CubeMX to the 
main.c of SW4

• Forward declare the copied 
functions

• Copy the inner code of the main 
function from CubeMX to SW4

SW4 – CubeMX Integration
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Using the BSP:
• Check the file “stm32f4xx_nucleo.c” in Utilities/STM32F4XX_Nucleo
• Modify the main as follows and run the code (right click->run as->Ac6):

SW4 – CubeMX Integration



Using the Sensor Expansion Board
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• Step 1:
• In SW4 click on File->import-> 

existing projects into workspace
• Click “Next”
• Browse to the MEMS1_V4.3.0 

folder and select Projects->Multi-
>Examples->IKS01A2-
>DataLogTerminal->SW4STM32-
>STM32F401RE-Nucleo

• Click “OK”
• Keep everything unchanged
• Click “Finish”

Importing an existing SW4 project

Sensor Expansion Board
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• Step 2:
• Compile and run
• Open a serial port terminal
• Configure ttyACM0 with 8n1 and 

115200bps
• You should see the sensor output

Importing an existing SW4 project

Sensor Expansion Board
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• Step 1:
•Import the DataLogTerminal example from MEMS framework 
home/ps/Desktop/resources/STM32CubeExpansion_MEMS1_V4.3.0/Projects/Examples/IKS01A1/D
ataLogTerminal/SW4STM32/STM32F401RE-Nucleo)

•Build the project

•Unplug the Nucleo and install the extension board

•Plug the Nucleo and program it 

Sensor Expansion Board
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• Step 2:
• Compile and run
• Open a serial port terminal
• Configure ttyACM0 with 8n1 and 

115200bps
• You should see the sensor output

Importing an existing SW4 project

Sensor Expansion Board



Sensor Expansion Board
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• Unplug the board and attach the sensor board on it
• Open the STM32CubeExpansion_MEMS1_V4.3.0

• Drivers
• BSP -> You need mems drivers (Components folder), Board 

adaptation files (X_NUCLEO_IKS01A2 folder). Don’t need the 
generic L476 BSP file (you already have it)

• CMSIS -> Don’t need: already have your CMSIS library
• STMXXX -> Don’t need: already have your HAL driver

• Projects -> several examples
• Utilities -> GUI program for the PC (we won’t use it)
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WARNING!!!

• The imported project has several files linked in the 
framework folder

• It is highly unrecommended to change this project as the 
changes might affect other projects based on the same 
linked files

• Import the necessary file in a plain SW4 project instead.

Sensor Expansion Board
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• Step 1:
• Import an existing project in SW4
• Create a plain SW4 project with 

CubeMX settings merged in it

Merging an existing linked project in a plain one

Sensor Expansion Board
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• Step 2:
• Copy the BSP folder from MEMS_V3_0_0 to your main project folder
• Include the BSP folder as source folder by right-clicking on the project-

>properties->C/C++ General->Paths and Symbols->Source Location-
>Add Folder

Merging an existing linked project in a plain one

Sensor Expansion Board
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• Step 3:
• Filter out every c file in this folder that it is not used in the imported project: 

right click on a file -> resource configure->exclude from build (check the files 
that are used by navigating the imported project first)

Merging an existing linked project in a plain one

Sensor Expansion Board
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• Step 4:
• Righ-click on the project->properties->C/C++ General->Paths and Symbols-

>includes and selecting GNU C as “Languages”
• Add all the relevant folders that uses headers related to the new BSP folder 

(every used subfolder)

Merging an existing linked project in a plain one

Sensor Expansion Board
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• Step 5:
• Righ-click on the project->properties->C/C++ General->Paths and Symbols-

>symbols and add existing symbols that are present in the imported project

Merging an existing linked project in a plain one

Sensor Expansion Board
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• Step 6:
• Import interrupt handlers from the 

stm32l4xx_it.c file
• Import MCU initialization functions 

from the stm32l4xx_hal_msp.c file
• Import BSP headers in your 

main.h and in any other file where 
it is required

Merging an existing linked project in a plain one

Sensor Expansion Board
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• Step 7:
• Copy whatever you want from the 

main.c file
• Fix the remaining minor issues 

(check for errors, check missing 
files/functions, optionally initialize 
peripherals with CubeMX etc…)

Merging an existing linked project in a plain one

Sensor Expansion Board



Bluetooth Expansion Board

84Intecs Solutions 2017 – Roma-Genova-Milano-Napoli-Pisa-Torino



Sensor Expansion Board
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• Unplug the board and attach the Bluetooth board on top of 
the sensor board

• Open the STM32CubeExpansion_BLE1_V2.8.0
• Drivers

• BSP -> You need board adaptation files (X-NUCLEO-IDB0xA1 folder). 
Don’t need the generic L476 BSP file (you already have it)

• CMSIS -> Don’t need: already have your CMSIS library
• STMXXX -> Don’t need: already have your HAL driver

• Middlewares -> You need the whole folder
• Projects -> several examples
• Utilities -> GUI program for the PC (we won’t use it)
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• Step 1:
• In SW4 click on File->import-> 

existing projects into workspace
• Click “Next”
• Browse to the MEMS1_V3.0.0 

folder and select Projects->Multi-
>Applications->SensorDemo-
>SW4STM32->STM32L476RG-
Nucleo

• Click “OK”
• Keep everything unchanged
• Click “Finish”

Importing an existing SW4 project

Sensor Expansion Board
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• Step 2:
• Compile and run the example 

application
• On your Android or iOS 

smartphone install “blueNRG” 
from the store

• Launch the phone application and 
bind the Bluetooth board

• You should see a cube that 
rotates each time you press the 
user button on the board

Importing an existing SW4 project

Sensor Expansion Board
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Assignment (if there is time)

• Merge the Bluetooth framework in your Accelerometer 
project

• Send actual data from the accelerometer to the 
smartphone

Sensor Expansion Board



Thank You!

Master thesis: ugomaria.colesanti@intecs.it
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